VoiceGuide IVR Software Main Page
Jump to content

Running vbscript on VoiceGuide 4 professional version

Recommended Posts


My company has been using VoiceGuide with a 4-line Professional Version license, I was asked to develop a script to read from a text file and proceed depending on the values of the file.

I took an example script that resides on "OpenClosedOrHolidays" project in the VoiceGuide directory, I made some changes to adapt it to our necessities. For testing, I used the DIALOGIC HMP driver and installed VoiceGuide as VOIP service, once developed, installed and tested the script ran all right.

Now when I tried installing the same script on the PC hosting the VoiceGuide with the license, the script wouldn't run, it would just stay "On Hold". One difference I can mention is that this PC is running VoiceGuide 4 and with a dialer service, meaning I can call it from a Phone.

Can you help me understand why this happens and if there’s anything I can do to make it work?

This is the Call_Event log I get when I call:

{ "call": {

  "crn": "1000000a",

  "port": "2",

  "direction": "in",

  "time_start": "2021-08-23 11:15:42",

  "events": "








    111542.547|state|Ring 1 connected|||||0|0|0|0

    111542.549|state|[Clear retries counter] Evaluate [0]|||||0|0|0|0

    111542.551|state|[Welcome] Playing wav (C:\Program Files\VoiceGuide\Scripts\Vac\Wav\welcome.wav)|||||0|0|0|0




    111545.068|state|[Check System Online] RunScript vbs, onhold=|||||0|0|0|0














  "length": "21.848"


The painted line is the VBScript it’s trying to run but it won’t continue to the next modules.



Share this post

Link to post

Please post the "vgEngine" trace that captures the call. We can then see what happened on the call and advise.

The vgEngine traces are created in VoiceGuide's \log\ subdirectory.

Please .ZIP up the traces before posting.


Share this post

Link to post

Ok, I took a look into the trace file, I saw one error I already handled, which was it didn't find the file, the second error is indicating that I may try using WSH instead of ClearScript, I tried changing the engine as suggested in trace file but it still doesn't work.

You can see both traces in ZIP file, my suggestion is to search for keyword "Yoman" to find the section with the script, hope it helps.

Thank you for the support!

vgEngine Traces.7z

Share this post

Link to post

The trace shows that the ClearScript interpreter that ran the [Check System Online] module reported:

ERROR ErrorDetails: Input past end of file

Probably next step would be to confirm if the system can read in the input data file.

Recommend adding some Trace API calls to see how far the VBScript code progresses.

see: https://www.voiceguide.com/vghelp/source/html/com_trace.htm


As you are running an older version then you may need to use the older Admin_TraceLogAdd API call instead of the Trace API.



Share this post

Link to post

Hi, thanks for the quick response, before I even tried adding the traceLog, I found out that the script needed a little "touch", since it was also alerting about a "End of File" error, I added an if statement to handle this error, but then I came to realize that I had an unneeded space in my If statement, and it kept alerting about an "Expected Then" error statement, once I fixed it the script ran smoothly but now I'm getting this error:

184330.231  24   3   2       not saving script (strIni_moduleRunScript_SaveToFile is False|0)
184330.231  24   3   2       runscr waiting. wait=1
184330.231  24   3   2       moh file not specified
184330.231  24   3   2       runscr call ClearScript Execute
184330.231  24   3   2       runscr new VBScriptEngine call
184330.232  24   3   2       runscr .Execute call
184330.233  25         rem   remoting link constructor activated: vgServices_CommandLink
184330.234  25         rem   Printed from trace: Starting vbscript
184330.236  25         rem   Printed from trace: Created fileReadingObject
184330.242  25         rem   Printed from trace: Opened text file with dates
184330.243  25         rem   Printed from trace: Success
184330.243  25         rem   Printed from trace: Starting to split lines
184330.244  25         rem   Printed from trace: Starting to read each line
184330.259  25   3   2 rem   Script_Goto 3, , Sorry,
184330.263  25   3   2 ERROR: COM interface not supported in this version.
184330.264  25   3   2 rem   Script_Goto 3, , E_Sorry,
184330.264  25   3   2 ERROR: COM interface not supported in this version.
184330.265  24   3   2       engineVbs dispose call
184330.265  24   3   2       runscr .Execute returned. iRunWait=1
184330.265  24   3   2       runscr RunWait_1 script completed
184330.265  24   3   2       runscr sModuleClearScriptProcessWasCalledFrom is current module Check System Online, clearing setting
184330.265  24   3   2       runscr RunWait_1 taking fail path as script completed and no next module set
184330.265  24   3   2       FindNextVgmTitleInPathList: next module title is=[Get For English]

Is there anything else I can do to make it work?


Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now