VoiceGuide IVR Software Main Page
Jump to content

Not able to hear wav sound

Recommended Posts

Using evaluation edtion and dialogic D/4PCI CARD incomming  calls are getting connected but not able to hear wav sound after answering calls from called number. Simple script that receives calls and play a simple wav sound. Using latest voiceguide 7.5 v. Log files shows everything is fine . Help me to get resolve . Planned for buying standard edition.

Share this post


Link to post

Could you please .ZIP up the contents of VoiceGuide's \log\ subdirectory, and post the .ZIP file in this Support Forum thread.

We can then confirm what is happening on this system and advise.

 

Share this post


Link to post

Traces capture one call and they show that on that call the file PayGetID.wav was played, and completed playing 8.5 seconds later, and after 7 seconds was played again, again completing after 8.5 seconds. Then after 6 seconds as there was no input the script hung up the call.

The traces look fine and this is how they would look on a correctly working system.

Have you tested that the cards works using the sample applications provided with Dialogic System Release drivers? (you will need to stop the VoiceGuide service before using the demo apps from Dialogic).
 

566 120937.352  2056   4 fn    PlayStart(iLineId=4, sFileList=C:\Program Files (x86)\VoiceGuide\Scripts\Credit Card Payment\PayGetId.wav, sXMLOptions=)
...
571 120937.385  2056           play  wav: format=7, channels=1, hz=8000, bytes/sec=8000, bytes/sample=1, bits/sample=8, DataBlockSize=66787  C:\Program Files (x86)\VoiceGuide\Scripts\Credit Card Payment\PayGetId.wav
...
583 120945.884  2164   4 ev    TDX_PLAY (Play Completed)


590 120952.687  2056   4 fn    PlayStart(iLineId=4, sFileList=C:\Program Files (x86)\VoiceGuide\Scripts\Credit Card Payment\PayGetId.wav, sXMLOptions=)
...
595 120952.688  2056           play  wav: format=7, channels=1, hz=8000, bytes/sec=8000, bytes/sample=1, bits/sample=8, DataBlockSize=66787  C:\Program Files (x86)\VoiceGuide\Scripts\Credit Card Payment\PayGetId.wav
...
607 121001.161  2164   4 ev    TDX_PLAY (Play Completed)

614 121006.956  2056   4 fn    DropCall(sLineId=4, sXMLOptions=[(null)], crn=10000001)

 

 

 

Share this post


Link to post

sample applications are not available in  Dialogic System Release drivers. which i had downloaded from your website.

Share this post


Link to post

Are you using an actual original "D/4PCI" or the current "D/4PCIU" or its "D/4PCIUF" or "D/4PCIU4S" variants?

The original "D/4PCI" and "D/4PCI-Euro" are not supported by Dialogic SR6.0 drivers.

"D/4PCI" and "D/4PCI-Euro" are only supported by Dialogic SR5.1.1 drivers.

And only VoiceGuide v6 can work with SR5.1.1 drivers...

"

 

Share this post


Link to post

VoiceGuide v6 can be downloaded from the Downloads page. But we'd recommend sticking with VoiceGuide v7 and getting a newer D/4PCIUF or D/4PCIU4S card instead.

 

D/300-JCT card is for an E1 ISDN trunk, not an Analog line. Do you have an E1 (2MBit) ISDN trunk to connect to the D/300-JCT?

D/300JCT can be used with VoiceGuide v7 (and the Dialogic drivers for VoiceGuide v7).

Share this post


Link to post

Please also note that you should not try connecting an analog line into a port designed to accept an E1 or T1 trunk.

The analog line has a voltage on it that can electrically damage the E1/T1 interface circuitry, and also the analog lines are usually terminated with a RJ11 connector, and E1/T1 cards have an RJ45 connector. Pushing a RJ11 into a RJ45 socket can damage pins 1 and 8 in the RJ45 socket.

Share this post


Link to post

I tried to check d/4pci card with demo apps it's not working. Trying to make call from that card calls not orginatibg. I can only make hookoff and hookon. These two conditions are working fine. And I m having both the lines E1 and analog line. So I made separate connections for E1 CARD and analog card. I dont know how to test E1 CARD. 

Share this post


Link to post

When using the E1 card you cannot have the D/4PCI card in system at same time.

Please remove the D/4PCI card and ensure only the D/300JCT card is in system. Is the D/300JCT card detected and showing in the Dialogic Configuration Manager (DCM)?

Is the E1 ISDN trunk coming from a Telco or form your local switch? Either way, the E1's are usually configured as "Euro-ISDN", for which you should select the "CTR4" protocol in the DCM.

Please see here for more information on setting up ISDN:

https://www.voiceguide.com/vghelp/source/html/configisdnsetup.htm

Is your E1 trunk cabling a 'twisted pair' type? If yes then your E1 trunk needs to have an RJ45 plug on end of it, and be wired using the RJ-48C wiring pattern.

 

Once the card is started in the DCM then do you get the green light on the back of the card when you plug the E1 trunk into the RJ45 socket?

Once you are getting the green LED light on when plugging in the cable (and red LED when you unplug cable) then we can move onto configuring VoiceGuide.

(you basically just need to change the Config.xml file in VoiceGuide and restart VoiceGuide)

Share this post


Link to post

D/4PCI and  D/300JCT  cards are in separate pc's. And E1 trunk is coming from telco it is loop tested from telco and it is found ok. 

when i tested D/4PCI card with voice demo app calls are not getting in and out. only hookoff and hookon functions are working ok.

 

Share this post


Link to post

The original "D/4PCI" and "D/4PCI-Euro" are not supported by Dialogic SR6.0 driver s.

You will need to replace the "D/4PCI" for a:  "D/4PCIU" or "D/4PCIUF" or "D/4PCIU4S"

Are you trying to get the D/300JCT working with an E1 trunk as well? Are you getting the green LED light on (on the back of the Dialogic card) when the E1 trunk is plugged into the card?

 

Share this post


Link to post

Please place the config.xml file attached at bottom of this post in VoiceGuide's \conf\ subdirectory on the D/300JCT system.

Then restart the VoiceGuide service and place a call into the system over the E1 trunk.

After the call please .ZIP up the contents of VoiceGuide's \log\ subdirectory and post the .ZIP file here.

We can then confirm if the call arrived and was answered OK.

More information on setting up ISDN and testing the Dialogic card using Dialogic's own utilities can be found here:

https://www.voiceguide.com/vghelp/source/html/configisdnsetup.htm

 

NB. An example config.xml file showing what the configuration to use with an E1 ISDN connection would have been placed in the VoiceGuide's \conf\ subdirectory at install time. The attached config.xml is based on that file, but with the directory of the script to use updated.

 

config.xml

Share this post


Link to post

Sounds like the config.xml file was not changed. Have you placed the previously attached config.xml in the VoiceGuide's \conf\ subdirectory and restarted the VoiceGuide service?

 

Could you please .ZIP up the contents of VoiceGuide's \log\ subdirectory, and post the .ZIP file in this Support Forum thread.

We can then confirm what is happening on this system and advise.

 

 

Share this post


Link to post

telco informed they dont know about CTR4 just they given one E1 which is having 30 voice channels and they are using cas signalling.

here i have attached log file

log.zip

Share this post


Link to post

Latest vgEngine trace shows that the correct config.xml is still not used.

Please download the previously attached config.xml and then place it in the VoiceGuide's \conf\ subdirectory (overwriting file that is there) and then restarted the VoiceGuide service.

After restarting the service please .ZIP up the contents of VoiceGuide's \log\ subdirectory, and post the .ZIP file in this Support Forum thread.

We can then confirm hos the card is initializing.

 

Also, the card in your system is being reported as not a D/300JCT, but as a: D30W1P

Can you confirm what model card you are using?

Are you using a 75ohm Coaxial cable for this E1 ?

024 134712.792  4448           ncm [DIALOG/HD-PCI][D30E1P #1 in slot 4/0][FX031713]

 

 

Can you ask Telco if they can provision this line as ISDN instead of CAS?

CAS is rarely used on E1 trunks. Some introductory  information on setting up a Dialogic E1 card to communicate using CAS over the E1 is provided here:

https://www.voiceguide.com/vghelp/source/html/configt1e1_cas_setup.htm

but changing that E1 to use ISDN is a much better option (protocol is: Euro-ISDN or E-DSS1)

Share this post


Link to post

now  config.xml is running and in line status window i got 30 channel lines but in that status getting blocked. and in backside of the card showing red light.

how do i create spandti.prm and voice.prm. in dialogic driver i dont get this files. tell me how to configure 

 

CAS is rarely used on E1 trunks. Some introductory  information on setting up a Dialogic E1 card to communicate using CAS over the E1 is provided here:

https://www.voiceguide.com/vghelp/source/html/configt1e1_cas_setup.htm

Share this post


Link to post

Can you ask Telco if they can provision this line as ISDN instead of CAS?

Also: can you confirm what model card you are using? The card in your system is being reported as not a "D/300JCT", but as a: "D30W1P"

Are you using a 75ohm Coaxial cable for this E1 ?

Share this post


Link to post

no i m using 4 wire E1 cable. now  in backside of the card showing green light but not able to see line on lines status. i had updated config.xml file which u sent me previously. 

and telco are not ready to give on ISDN. so kindly guide me resolve with CAS..

Share this post


Link to post

Can you confirm what model card you are using? The card in your system is being reported as not a "D/300JCT", but as a: "D30W1P"

After restarting the service please .ZIP up the contents of VoiceGuide's \log\ subdirectory, and post the .ZIP file in this Support Forum thread.

Share this post


Link to post

log.zi here i have attached log file. now i am able to get green light on back side of the card. i m using "D/300JCT" card only.

Share this post


Link to post

ktTel_Completion (genericEv) 10000 10003,GetTelLayerDetails, crn=0, 0,0,0,,D30E1P #1 in slot 4/0|FX031713,

Share this post


Link to post

 In the backside of the card showing green light but not able to see lines on line status. i had updated config.xml file which u sent me previously.

Share this post


Link to post

Was this card used with that E1 CAS line before?

There are 2 main configuration files that need to be provided to the Dialogic card for E1 CAS setups.

If this card was used with that E1 CAS line beforehand then those configuration files should have been set up already, and you should know what pdk and .prm files should be used with this Dialogic card to let it communicate over that E1 CAS.

 

You need to do:

In Dialogic Configuration Manager DCM, go to the interface tab and set ISDN protocol to "none"

Then go to the misc tab and select SPANDTI.PRM as the ParameterFile

Edit the file spandti.prm which is located in: “C:\ProgramData\Dialogic\data” directory, and set the line specs (coding and framing) to the E1 settings.

(Note that C:\ProgramData\ is a hidden directory, which you need to make visible first before viewing in in Windows Explorer.)

 

Then you will need to edit the config.xml and replace the ISDN setting with the name of the pdk file to use.

There are a number of ready to use pdk files in "C:\ProgramData\Dialogic\cfg"

You need to select the right one for your E1 CAS line configuration.

 

Do you maybe know what is the switch that supplies this E1 CAS line?

eg. for Nortel Meridian switch  the pdk to use is: pdk_sw_e1_ntmd_io

so if the CAS E1 comes from a Nortel Meridian switch then in config.xml all these lines:

<Protocol>ISDN</Protocol>

would be replaced by:

<Protocol>pdk_sw_e1_ntmd_io</Protocol>

 

Some more information on pdk protocols can be found here: https://www.dialogic.com/~/media/manuals/docs/globalcall_for_e1t1_v3.pdf

Share this post


Link to post

Trace shows the initialization does not return errors, and there are no errors on outgoing call attempt, but after 30 seconds the Dialogic divers advise call is disconnected. And afterwards there are some errors that seem to be protocol related.

Recommend trying to call into this system first and get the incoming calls working before trying to place outgoing calls.

If you can get some traces from the Alcatel then those may help to let you see what is happening.

 

225 181300.410  2576 116 fn    LineMakeCall(iLineId=116, iCallRequestId=0 (ignored), strNumberToCall=[257222], callprog=DX_PAMDOPTEN, timeout=60, params:0,0,cidtosend=[],opt=[])
226 181300.412  2576 116       makecall protocol is: non-ISDN
227 181300.412  2576 116       ResetVoiceBackToItsNetwork dxxxB6C3->dtiB1T23
228 181300.413  2576 116       reset_voice_to_dti begin dxxxB6C3:115 to dtiB1T23:114 (linedev=116)
229 181300.414  2576           scroute devtype1=1:SC_VOX devtype2=3:SC_DTI  1:line=116,net=114,voice=115  2:line=116,net=114,voice=115
230 181300.420  2576           CleanDialString [257222]=>[257222]
231 181300.420  2576 116       TelDriver_LineMakeCall hli->Dial_zsOtherCallProgressSettings=[]
232 181300.421  2576 116       Set_DX_CAP_ca_intflg zDial_DxCap.ca_intflg=DX_PAMDOPTEN
233 181300.421  2576 116       CallProgressOption=[DX_PAMDOPTEN] ca_intflg=269002732
234 181300.421  2576           MakeCall select driver. strDti=[dtiB1T23]
235 181300.421  2576           MakeCall driver non-HMP version used strDti=[dtiB1T23]
236 181300.421  2576 116       gc_MakeCall initialisation (SR)
237 181300.421  2576 116       set outgoing cid (116, []) ok
238 181300.421  2576 116       makecall defsrc none ()
239 181300.421  2576 116       gc_MakeCall [257222] call (SR60)
240 181300.421  2576 116       gc_MakeCall ok. crn=4010074
242 181300.422  2576 116       TelDriver_LineMakeCall returned 0, hli_Returned=10072758
243 181300.422  2576 116       TelDriver_LineMakeCall returned hli_Returned->crn_lastMakeCall=04010074
244 181300.422  2576 116 r     generic ktTel_Completion|10000  Completion_MakeCall|0  67174516 (67174516|0|0|257222||<result>ok</result><crn>67174516</crn><crnx>4010074</crnx>)
245 181300.422  2576 116       LineMakeCall TelDriver_LineMakeCall zsResult=[<result>ok</result><crn>67174516</crn><crnx>4010074</crnx>]
246 181330.431   192 116       ev 31 : type=826 crn=4010074, data=0516CCF0(0A76A4B8), q: 0/1
247 181330.431   192 116 ev    GCEV_DISCONNECTED crn=4010074
248 181330.431   192 116       Event_CallState GCEV_DISCONNECTED crn=0x4010074
249 181330.432   192 116 r     CallState(116, 4010074, 0, GCEV_DISCONNECTED, 16384, 0, 64, , , ) 

 

Share this post


Link to post

Now i took one sip account how do i configure voip sip account in voiceguide . send me the procedure plz

Share this post


Link to post
This topic is now closed to further replies.
×