VoiceGuide IVR Software Main Page
Jump to content

Disconnect Immediate

Recommended Posts

Hope someone can help me.


The situation:

Like the topic title, i call to the modem (Specs follow later). After 2 rings, the modem connects and suddenly the modem disconnects. Whatever i do, it will not help.



- USR Sportster Flash

- Wisecom 5614ES3CW


I've just bought the Wisecom serial external modem, because the USR modem wouldn't pick up. On this forum the USR brand is told to be bad for voice, so i bought a cheap (30 euro's) modem (no other serial voice modem where sold) with the Conexant/Rockwell chipset.

The OS is Windows 2000 server.


Where was also mentioned on this forum that not every voice modem is a voice modem, but only a speakerphone modem.

The manual on CD of the Wisecom modem mentioned voice AT commands (couple of pages long), so this is a voice modem?


The logfile:




After i hang up the phone (modem already disconnected the line) and pressed the disconnect button of IVG i get this:




This is for the Wisecom modem. The USR modem will only report like the first image and repeat it "ring 1, ring 2, ring 1, ring 2, ring 1, ring 2" etc.


I wonder if it is the voice audio driver.


IVG is BTW the latest version with the hotfix issue (of modem hangup?)





The Unimodem driver in Windows 2000 is reported to be working just fine:





But i don't know, if this error is common:




I got this error after getting the properties of the Unimodem driver and double clicked on the "Modem Wave Drive" at the properties tab.




Hope someone (maybe support?) can help me.



Share this post

Link to post

BTW: There is no sounddriver installed. Is this correct?



Share this post

Link to post

It looks like your modems Wave drivers have not been correctly installed.


It's best to ask the modem manufacturer's technical support why this is the case and how to fix it.


It is possible that your modem is not a Voice modem, and only a 'speakerphone' modem, or that the install process did not recognize your modem as a voice modem and did not install the 'voice' version of drivers, resulting in Windows treating your modem as just a normal modem...

Share this post

Link to post

I've emailed the technical support, but no answer yet.


I've tried the software that was delivered on CD with the modem and surprisely the software acted as a answering machine, worked just fine.


Below you'll find a screendump of the modem properties of this application called "FaxTalk Communicator" :




I don't know but the software found a Rockwell SP 3131 driver. In the pulldown menu there is also a Rockwell ADPCM.

Is it possible you don't use this chipset but use it via a driver build in Windows (The unimodem driver?).


The voice driver must be from the manufacturer or can i also use another driver from another manufacturer or must i use the unimodem driver from Microsoft?

Share this post

Link to post

It looks like "FaxTalk Communicator" has it's own drivers to communicate with the modem directly, instead of using the TAPI/Wave drivers.


This approach was used by older versions of VoiceGuide - you can still download v2.9 of VoiceGuide from our WWW, see the very bottom of page:




The current version of VoiceGuide requires that the modem/telephony card supports TAPI/Wave drivers.

Share this post

Link to post

Okay it looks like in Terminal Services of Windows 2000 server, the sounddriver is not activated nor the Modem Wave Drive will function.

On the console itself everything works.




Now i've used a new Creative Modemblaster V92 serial with Rockwell chip (conexant). There is a sounddriver installed :




But the system still drops the line after a connect. So i deinstalled Voice Guide. Restarted, installed the version on your website (4.8.45). Still same problem. Updated Voice Guide with version 4.8.51. Result was the same problem.


What can it be?


BTW: The trace log reports the same thing "ring 1, ring2" picks up the line and disconnect it immediately

Share this post

Link to post

In the screen capture of the trace window we saw "ring 1" and "ring 2" but there was no trace of an attempt to answer the call by VoiceGuide...


Do you have anything else running on the system which could have answered the call?


Can you close any other applications (FaxTalk ?) and dial in again - then post the trace here,


The wave drivers look good.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now