VoiceGuide IVR Software Main Page
Jump to content

Not able to put input in a script

Recommended Posts



I was able to successfully setup the HMP drivers and get voice guide running, but when I call the SIP number and the script starts to run I can't get any input to actually work. I believe it is all setup correctly inside the paths as I even have used several of the templates included in the program and still just cannot get any input to actually go through and have the IVR system respond to the touchpad keys.

I have enabled HPET through the command line 

here are the logs

voiceguide ktel log.txt


Share this post

Link to post

VoiceGuide ktTel and WireShark traces show a number of calls made into the system and answered by VoiceGuide.

The system is running in a single line evaluation mode, so calls made while there is already an active call on the system are rejected.

On the calls that were answered no keypress/touchpad events were detected.

Was the calling system sending the keypress tones as tones that were part of the transmitted sound? Or as RFC-2833 messages? or some other type?

Did the caller hear the sound files played by VoiceGuide?

As a simple test can you set VoiceGuide to use a script that just plays a short sound file and then starts a recording, and do the following:

  1. Restart VoiceGuide.
  2. Start WireShark on the same system VoiceGuide is running.
  3. Make a single call into the system.
  4. Confirm you can hear the sound file played by VoiceGuide.
  5. When recording starts press some keys on the touchpad.
  6. Hangup the call.
  7. Stop WireShark and save the .pcapng trace.
  8. Post the captured WireShark trace, VoiceGuide ktTel trace, and the recorded sound file.

This will allow for confirmation of whether the voice RTP connection is working in both directions and if the keypress actions are being transmitted.


Also, the HPET timer still shows as disabled. From ktTel trace:

016 175915.314  5908         WARN  HPET not enabled. Enable HPET timer and restart Windows. QueryPerformanceFrequency -2147483648MHz (quad=15374029784130280)
017 175915.314  5908         WARN  command to enable HPET: bcdedit /set useplatformclock true

Please try restarting Windows OS and see if HPET works after that.




Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now