VoiceGuide IVR Software Main Page
Jump to content

Web Service with Certificate

Recommended Posts

How do you use the Webservice module to to a HTTPS Post Request with a certificate for authentication?

Under the options TAB for the module there is Simple Authentication (username and password) and No Athentication.

Where is the certicate accommodated?

 

Share this post


Link to post

Do you want to use a "Client Certificate" when making a POST ? (as opposed to a "Server Certificate" which HTTPS servers have).

Has your client certificate been loaded into the "Windows Certificate Store" on the system where VoiceGuide is running, or do you just have a file that you want the Web Service module to read in and use? If a file then is it a ".pfx" format file, or some other format?

Share this post


Link to post

Yes I am using a "Client Certificate" and it is installed in the Windows Certificate Store" on the system that VoiceGuide is running.

Share this post


Link to post

We added ability to use certificates from Windows Certificate Store in this version:

[Link Removed]

Please see the below instructions.

If you encounter any issues please post the latest 'vgEngine' trace file from VoiceGuide's \log\ subdirectory. This way we can see what is happening on the system.

 

Updating VoiceGuide

To update to newer version of VoiceGuide:

1. Stop VoiceGuide Service.

     VoiceGuide Service can be stopped by clicking on the VoiceGuide Service Monitor in the Windows's Icon Tray on bottom right of the taskbar and selecting "Stop".

2. Exit all VoiceGuide programs.

This  includes the Service Monitor applet in the Icon Tray area in bottom right of the screen,  as well as the Script Designer, Line Status Monitor, etc.

3. Run the VoiceGuide install and install into same directory as existing installation.

    (Do NOT uninstall the previous VoiceGuide installation).

4. Start VoiceGuide service.

Note: Running a VoiceGuide install over the top of an existing install will NOT overwrite existing configuration or license files (Config.xml, ConfigLine.xml, VG.INI, etc) and will not remove any of users script or sound files, and will not remove any log files etc.

 

Using Client Certificates

To have the Web Service module use a "Client Certificate" from a Windows Certificate Store specify this in the Web Service module 'Options' text box:

<ClientCert_FromStore_FriendlyName>MyCertFriendlyName</ClientCert_FromStore_FriendlyName>

The "MyCertFriendlyName" must match the "Friendly Name" setting set for that certificate in the Windows Certificate Store.

 

To have the Web Service module use a "Client Certificate" from a .pfx file specify this in the Web Service module 'Options' text box:

<ClientCert_Filename>c:\mydir\myfilename.pfx</ClientCert_Filename>
<ClientCert_Password>myPassword</ClientCert_Password>

 

Edited by SupportTeam
remove link

Share this post


Link to post

I have carefully followed the installation instructions. However, the VG system is not starting. I am gettting an error "Dialogic drivers not installed. Please install Dialogic and try again."

Please note that the Dialogic HMP is installed and i went through the process of re-installing it when i first got the error message. The Dialogic HMP starts without any problems.

The Windows Event Viewer has this entry

Log Name:      System
Source:        Service Control Manager
Date:          2/16/2021 6:20:18 AM
Event ID:      7023
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      WIN-2UTKMATN7GC
Description:
The description for Event ID 7023 from source Service Control Manager cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

VoiceGuide IVR
%%4294967286

The locale specific resource for the desired message is not present

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
    <EventID Qualifiers="49152">7023</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2021-02-16T11:20:18.820096000Z" />
    <EventRecordID>12891</EventRecordID>
    <Correlation />
    <Execution ProcessID="700" ThreadID="3516" />
    <Channel>System</Channel>
    <Computer>WIN-2UTKMATN7GC</Computer>
    <Security />
  </System>
  <EventData>
    <Data Name="param1">VoiceGuide IVR</Data>
    <Data Name="param2">%%4294967286</Data>
    <Binary>56006F006900630065004700750069006400650020004900560052000000</Binary>
  </EventData>
</Event>

Share this post


Link to post

Was the VoiceGuide service stopped and all of the VoiceGuide applications were exited before installing the new version? (this includes the VoiceGuide License Manager app and the VoiceGuide service monitoring app in the Icon Tray)

If old apps were running then the new installer would not be able to install new version .EXEs and .DLLs and you will have old .DLLs still in your VoiceGuide directory, which would lead to an issue like you describe.

Please try the following:

  1. Stop VoiceGuide Service and exit all VoiceGuide applications.
  2. Delete all .EXEs and DLLs from VoiceGuide directory.
  3. Run installer for new version again.

If you still encounter any issues please post the latest 'vgEngine' trace file from VoiceGuide's \log\ subdirectory. This way we can see what is happening on the system.

Share this post


Link to post

It looks like there are are some old .DLLs from previous version still on this system.

Did you successfully delete all of the ..EXEs and DLLs from VoiceGuide directory before running the new installer?

vgEngine trace shows:

195154.680   9                     LoaderExceptions: Could not load file or assembly 'ktTelCommon, Version=7.6.7519.37742, Culture=neutral, PublicKeyToken=81bdcc44759ecdc5' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

The "ktTelCommon.dll Version=7.6.7519.37742" is from an old install.

The file that comes with the latest  version provided is: "Version=7.6.7717.27380"

 

Software is not starting as it is checking that the matching versions of DLLs are on the system - which right now they are not.

Share this post


Link to post

I did delete all the .exe and .dll files in the VoiceGuide folder. Are there other files to be deleted that may be in the subfolders?

 

Share this post


Link to post

Looks like a wrong file was included in the previously provided patch release installer.

(not ktTelCommon.dll, a different .dll)

We will build a new patch release installer and provide that.

Share this post


Link to post

Please let us know if VoiceGuide now starts up OK for you, otherwise please post the vgEngine trace as before.

Share this post


Link to post

Yes, it has started. As soon as the functionality regarding the Certificate is tested I will advise.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×