VoiceGuide IVR Software Main Page
Jump to content

Hmp Problem

Recommended Posts



I am trying to install HMP 3.0 update 371 to windows server 2012 R2 befoer installing VG 7.5 for Voip.

I tested with hpettool64 ( as I want to run everything in 64 bit) and based on https://www.dialogic.com/-/media/manuals/hmp30win/release_install.pdf I did the full install following this link https://www.dialogic.com/en/products/media-server-software/download/hmp-windows.aspx.

During installation, I was given default directory Program Files (86). I have changed it to Program Files/Dialogic/HMP and installed HMP there.

Following instructions I also modified "Dialogic service to start automatically. This can be set using DCM 's Settings -> System/Device autostart -> Start System ".

Currently Dialogic System Service stuck in "Starting" status and all dialogic related services display "Failed to read descriptio. Error Code:2".


DCM was not responsive either and nothing can stop this - reboot, clean, etc.


Please help.



We bought a license from you but it has not been given to us yet. I am installing this ahead of time as it was recommended to us by VG sale rep ""Would recommend proceeding with install of HMP and VoiceGuide as we need confirmation that system is working in evaluation mode prior to issuing licenses."





Share this post

Link to post

Dialogic HMP is 32 bit software, as are the Dialogic "System Release" drivers.


VoiceGuide is also 32 bit software - as it links to 32 bit Dialogic drivers.


Please uninstall the current HMP install (do NOT save the configuration), then restart system to complete uninstall, and then install HMP again, accepting the default settings.


Can you please advise what CPU is being used on this system? Is Win2012R2 installed directly on the server or is it being ran in a Virtual Machine?

Share this post

Link to post

System Model : VMware Virtual Machine

System BIOS 6.0

CPU Duel 2.6 GHz Intel Xeon®E5-2650 v2

Memory 4096 MB

OS Windows 2012 R2

No service packs

Share this post

Link to post

ANother question: when I run utility hpettool32 on WIN2012R2 it said this utility will not run on 64 bit. when I ran hpettool64 - it is OK. Then it is not clear why Dialogic needs to be installed on 32 and not 64..




Share this post

Link to post

Is "VMWare ESXi" used (the one that is installed on 'Bare Metal'), or is "VMware Workstation" used ?


If "VMWare ESXi" then can you please advise which version of ESXi is used.

Share this post

Link to post

Could you please post a screenshot of the administration screen, and the screen where this "NECVMware hardware" is mentioned.


Are you hosting this system on a "cloud" service or is the machine that this VM is running on is owned by you?


Are you able to speak with the Administrator for the machine on which this VM is running?

Share this post

Link to post

While I am waiting for the production license I requested and installed trial lic. from Dialogic for HMP.

It looks like all software installed and running. But the ipmediaserver is failing. Pleasee see attachments.






Share this post

Link to post

Does the text on the right hand side of the first screenshot appear as part of the background when running this VM? Or was it cut and pasted from somewhere else?


Could you please ask the administrator of the system on which this Vm is running to clarify how is this VM provisioned:


Is it a 'standard' ESXi setup or something else? ( "NECVMware hardware" ?)


If it is a 'standard' ESXi setup then can they please advise which version of ESXi is used?

Share this post

Link to post

This VM is running on an ESXi host version 5.5.0 build 2143827….


Also can let me know if i need to add any drivers/devices to be shown in Dialogic config from the my attachment above.



Share this post

Link to post

Would suggest taking that VM back to original fresh Win2012R2-only image, and then installing HMP and using the default install directory


Please make sure to select ALL the check boxes when HMP Installer asks what 'Options' to install.


Then please post screenshot of ipmediaserver.exe (as before) and please .ZIP up the contents of Dialogic HMP's /log/ subdirectory and post it here.

Share this post

Link to post

Would suggest taking the VM back to stage before HMP was ever installed on it. To make sure that that the other install in non-standard directory is not affecting anything.


That should take it back to original fresh Win2012R2-only image, yes? Or was other software also installed on this VM before HMP was installed?

Share this post

Link to post

No nothing else was installed before HMP.


Also, do I need to have sound card, video card or equivalent software installed on that VM?


Anyway I can clean up as noone will be able to reinstall VM until Monday....?

Share this post

Link to post
Also, do I need to have sound card, video card or equivalent software installed on that VM?


No need to have sound card etc.

Share this post

Link to post

VM was reinstalled.

I installed all : HMP (tested OK with testing utility and linphone); VG7.5.7, Mysql. But the outbound calls are not getting through.


I am using trial version while waiting for the production license....So I am restarting VG every hour. So I configured congif.xml with only one SIP and chanel.


Please look at my logs, config.xml and vg.ini and let me know what is the problem that I am not getting outbound calls.


Please change extention Conf.txt to Conf.7z to see config and vg.iniConf.txt0305_1558_vgEngine.zip


Thank you!



Share this post

Link to post

Traces show that two incoming call arrived at system but were not answered as system was running in evaluation mode for too long:

164711.173  22   3   1 ev    CallState GCEV_OFFERED, crn=8000001, iEvent=0 ,2,0,8, s1:dozortsi@trinity-health.org|, s2:linphone@, s3:]. build_date: 30-Sep-16 18:52:14.30

192029.068  23   3   1 ev    CallState GCEV_OFFERED, crn=8000001, iEvent=0 ,2,0,8, s1:dozortsi@trinity-health.org|, s2:linphone@, s3:]. build_date: 30-Sep-16 18:52:14.30

To test that incoming calls are being answered please place a call into the system within a few minutes of starting the VoiceGuide service.



Regarding outgoing calls: As this is a HMP VoIP system, the outgoing calls need to be made to the IP address of the VoIP Switch or PBX or Gateway that is able to then forward that VoIP call. The dialed number is usually specified as:








(replace with IP address of your VoIP Switch / PBX / Gateway.


Whatever VoIP Switch / PBX / Gateway is used to route the outgoing calls it would be good to send some test calls into VoiceGuide through that VoIP Switch / PBX / Gateway first.


If you have any issues with placing the VoIP calls please make capture of VoIP SIP traffic using WireShark ( see: http://www.wireshark.org )

Best to include capture of incoming call as well as the outgoing call.

Share this post

Link to post

There are a few Database related issues on this system as well, which, although not affecting the placing of calls during testing phase, should be addressed before going live:


The traces show that this system was set up to use MySQL as the backend database that stores the outgoing calls and reports etc.


However the OutDialQue_SqlPrefix and the OutDialQue_SqlSuffix entries have not been set for this connection in the Config.xml


Please refer to http://www.voiceguide.com/vghelp/source/html/dial_vgdb_external_config.htm for details as to what these need to be for MySQL database.


Also please see attached the latest version of the Db_Create_MySql.Data.MySqlClient.sql file, which is used by VoiceGudie to create the tables it he database.


Please unzip and place the Db_Create_MySql.Data.MySqlClient.sql file in VoiceGuids's \system\setup\ subdirectory (overwriting previous file).

Then exit all VoiceGuide programs and services and drop all tables in the MySLq database and then start the Telephone Number Loader app. This will then result in all the tables and indexes being created in the database as per the new Db_Create_MySql.Data.MySqlClient.sql file





Share this post

Link to post

I changed config to use he phone infront of IP for Cisco SIP trunk, changed param for mysql, dropped schema and rebuilt it from the new SP you sent.


I see that voip calls attempts in wireshark but it all endup as 404.


Also config currently setup to use phone@IP, it production it will be always different outgoing numbers so I need to remove the number eventually. Question about username and password for VOIP - are they any I want or there is some restriction?


Ataching new logs, config and wireshark cap.



Share this post

Link to post

Traces show that the CISCO CUCM server (Cisco-CUCM10.5) at IP address replied to the INVITE sent to it with a 404 "Not Found" status.


The Q.850 cause code given was "1", which indicates an "Unallocated Number" / "Unassigned Number", so looks like the Cisco-CUCM at is not configured to proceed with INVITES from VoiceGuideIP address and/or to the specified number. That will need to be resolved first if you want to place your VoIP calls though that system.


Suggest also setting up a number of that Cisco-CUCM that sends the calls to your system IP address when a certain number assigned to that Cisco-CUCM is dialed. This will let you in future to quickly test this Cisco-CUCM <-> VoiceGuide/HMP connectivity by just dialing that number and hearing/seeing VoiceGuide answer.


But perhaps the Cisco-CUCM is setup to allow the calls if the VoiceGuide system registers itself with Cisco-CUCM first?



And it looks like you would like for VoiceGuide to SIP register itself with the Cisco-CUCM, but currently there is an issue in the registration config:


The <RegServer> entry in Config.xml should just contain the IP address (or resolvable fully qualified domain name - FQDN).


Please change this and then post WireShark trace that captures VoiceGuide service startup - we can then see in WireShark how the SIP REGISTER progresses.



Question about username and password for VOIP - are they any I want or there is some restriction?


No restriction on VoiceGuide side. Both of these will need to to come from Cisco-CUCM administrator.


Information on how to configure VoiceGuide to register itself is also here: http://www.voiceguide.com/vghelp/source/html/config_voip_register.htm

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now