VoiceGuide IVR Software Main Page
Jump to content

Email Stoped Working

Recommended Posts

I changed in my script and in voicemail manager a new smtp and it stoped working I tried to change back to original still not working enclosed is log files thanks Eli


Share this post

Link to post

Could you please post some traces that capture email sending when the old SMTP was still working?

Share this post

Link to post

The 1231_0828 log file captures one email being sent (forwarding a voicemail message saved in mailbox), and it was sent successfully:

082940.196 14               [Voicemail]:ForwardVmEmail_IncludeWavFile = 1
082940.196 14   1   1       vm    forward vmb 119 email to zsrebmeir@thejnet.com (wav attached)
082940.196 14               AddEmailToSend from:RebMeir@theJnet.com|voice guide, to:zsrebmeir@thejnet.com, cc:, bcc:, reply:RebMeir@theJnet.com, subj:Voicemail: ,  on 12/31/2014 8:29:40 AM at 08:29:40, att:C:\Program Files (x86)\VoiceGuide\data\VmSave\119_1231082940_1_1__001.wav, usertoken:(<to>zsrebmeir@thejnet.com</to><subject>Voicemail: ,  on 12/31/2014 8:29:40 AM at 08:29:40</subject><guid>69ad4a5e-1987-4d7d-87a6-99f684b32430</guid>) smtp:smtp.thejnet.com|0 timeout:900sec, sParamsXml:
082940.196 14               SmtpClient created ok
082940.196 14               .Host=smtp.thejnet.com .Port=25 .EnableSsl=False sCredentialUserName=[RebMeir@theJnet.com]
082940.196 14               SmtpClient clientEs configured ok
082940.196 14               email send start <to>zsrebmeir@thejnet.com</to><subject>Voicemail: ,  on 12/31/2014 8:29:40 AM at 08:29:40</subject><guid>69ad4a5e-1987-4d7d-87a6-99f684b32430</guid>, timeout=900sec082941.887 19         email sent ok. <to>zsrebmeir@thejnet.com</to><subject>Voicemail: ,  on 12/31/2014 8:29:40 AM at 08:29:40</subject><guid>69ad4a5e-1987-4d7d-87a6-99f684b32430</guid>

082941.887 19         email sent ok. <to>zsrebmeir@thejnet.com</to><subject>Voicemail: ,  on 12/31/2014 8:29:40 AM at 08:29:40</subject><guid>69ad4a5e-1987-4d7d-87a6-99f684b32430</guid>

In the previously supplied traces there is one email send attempt in 0721_1301 log (made using a 'Send Email' module) :

130359.684  6   1   1 state [Send Email NoAttachment] Send Email
130359.684  6   1   1       rv    replace start [$RV[GetPhoneNumber], $RV[ExpMM],$RV[ExpYY], $RV[Amount], $RV[AuthNet_Authorization_Code], $RV[ResEchoice], $RV[ChoiceNer], "]

130359.685  6   1   1       email to: zsRebMeir@theJnet.com
130359.694  6               AddEmailToSend from:voicemaileliposen@gmail.com|Reb Meir Bal Hanes, to:zsRebMeir@theJnet.com, cc:eliposen@hotmail.com, bcc:, reply:voicemaileliposen@gmail.com, subj:ivr system transaction, att:, usertoken:(<to>zsRebMeir@theJnet.com</to><subject>ivr system transaction</subject><guid>33f2f7ce-1b84-49a8-9055-a223ba827612</guid>) smtp:smtp.gmail.com|465 timeout:3000sec, sParamsXml:
130359.702  6               SmtpClient created ok
130359.705  6               .Host=smtp.gmail.com .Port=465 .EnableSsl=False sCredentialUserName=[voicemaileliposen@gmail.com]
130359.706  6               SmtpClient clientEs configured ok
130359.706  6               email send start <to>zsRebMeir@theJnet.com</to><subject>ivr system transaction</subject><guid>33f2f7ce-1b84-49a8-9055-a223ba827612</guid>, timeout=3000sec
130359.741  6               email SendAsync returned
130359.741  6   1   1       email queued for sending.

The successful voicemail forward email was sent through : .Host=smtp.thejnet.com .Port=25 .EnableSsl=False sCredentialUserName=[RebMeir@theJnet.com]


The unsuccessful 'Send Email' module email send was attempted through: .Host=smtp.gmail.com .Port=465 .EnableSsl=False sCredentialUserName=[voicemaileliposen@gmail.com]



For smtp.gmail.com most likely authentication is required - and looks like that option was not enabled in the 'Send Email' module, so first step would be to try doing that (involves specifying the gmail user/password in the Send Email module).


If that does not work then the next step would be to use the same smtp as was used by the working case: smtp.thejnet.com



SMTP connectivity is best debugged using WireShark (www.wireshark.org) so that may need to be used if problems are still encountered after trying the above.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now