Jump to content


< Back to Forum


 

Vg 7 Say Digits


  • Please log in to reply

#1 newpop1 27 June 2008 - 08:21 AM

We have :

-Windows 2003 STD Server
-LOCAL T1:DYNAP 23+1D VOICE
-Dialogic DMV600BTEPeq combined media board
-registered VG 7.0, CLR version 2.0.50727.1433, not sure how to even get a VG version anymore, used to be Help, about. VG Scrit and Manager show version 6.xxx?? why?

Have several problems:

1) We moved the scripts from VG 5.x, it is a simple script and when VG7 hits module to speak number/date/etc, the wav file defined in "play before" plays ok, but the digits to be spoken are pulled from variable, it is very scratchy and sound awful!!. However if you put the numbers to be spoken first from variable, then the numbers sound just fine and if I include a WAV in "Play after..", then that WAV file sounds scratchy and awful!!. help!!

2) The script is running very very slow in comparison to VG 5, is there a new setting that specifies a new delay between each module?

3) We have the Text to speech and changed the configuration to use the AT&T Natural voice and works fine , except it very fast, how can I slow the text to speech? No sound card in this server so I can't access it via control panel.

Thank You

#2 SupportTeam 27 June 2008 - 08:33 AM

QUOTE
1) We moved the scripts from VG 5.x, it is a simple script and when VG7 hits module to speak number/date/etc, the wav file defined in "play before" plays ok, but the digits to be spoken are pulled from variable, it is very scratchy and sound awful!!. However if you put the numbers to be spoken first from variable, then the numbers sound just fine and if I include a WAV in "Play after..", then that WAV file sounds scratchy and awful!!. help!!

The sound files you use need to be in the same format as the sound files in VoiceGuide's \system\voice\ subdirectory. This sound file format is selected at install time. Which did you select? ULaw or ALaw? (And what format are the sound files used as the "Before" and "After" sound files?

It's best to have everything on your system to be ALaw or ULaw. Match it to the encoding used on the ISDN lines. T1 ISDN lines usually use ULaw. (ALaw is used on E1 ISDN) But you can standardize an other format (eg PCM 16bit), you just need to ensure that the same sound files format is used by the script and is in the \system\voice\.
You can copy the sound files from your old v5 install and place them \system\voice\ if you'd like.

QUOTE
2) The script is running very very slow in comparison to VG 5, is there a new setting that specifies a new delay between each module?

Could you please post a copy of VoiceGuide's Trace Logs which captures the call, this will allow us to see what is happening.

Trace files are created in VG's \log\ subdirectory.
Please post the traces and the VoiceGuide script used.
When posting traces/scripts please .ZIP them up and post them as attachments.

QUOTE
3) We have the Text to speech and changed the configuration to use the AT&T Natural voice and works fine , except it very fast, how can I slow the text to speech? No sound card in this server so I can't access it via control panel.

Are you doing the TTS in a separate Play module all by itself, or is this as part of the Say Number module?
Again please post the traces (all the traces: ktTel and vgEngine and kTTS).

#3 newpop1 02 July 2008 - 09:09 AM

We installed uLaw and I confirmed that the WAV files in /system/voice folder are uLaw. I also verified that all the WAV files we use are all uLaw. I can't find within the log where the module is listed, the play sound module name is: Invalidid. The wav file NoScheduleForDivision.wav plays fine, but then the numbers sound awful and can't understand them. The play sound module is supposed to play the wav first and then the contents of the variable next.

Thanks
  • Attached File  logs.zip   27.63KB   94 downloads


#4 SupportTeam 02 July 2008 - 11:22 AM

Looking at the trace we can see that the file NoSheduleforDivision.wav does not appear to be used on a Say Number module, but is used in Play module.
And it looks like you are doing a TTS from the same module as well (which is used to say ",66666, for," or similar).

Do you know in what format the TTS Engine is creating the files? All the sound files that are played back to back need to be in the same format. So if you want to use TTS then change NoSheduleforDivision.wav to have the same format as the TTS generated files. Or you can just place the TTS in a separate Play module of it's own.

Why are you using the TTS to say the number? You would get better results from using the Say Number module, as the digits would be spoken using the pre-recorded sound files in VoiceGuide's \system\voice\ subdirectory.

#5 newpop1 03 July 2008 - 08:20 AM

Separating the TTS and the WAV did the trick. Apparently the TTS is in another format. If we installed VG and picked uLaw, shouldn't the TTS be in uLaw or is that controlled by the AT&T voices program directly?

Thank You

#6 SupportTeam 03 July 2008 - 08:26 AM

Most TTS engines cannot create uLaw or ALaw files, only PCM.

VoiceGuide v7 and Dialogic cards can play the basic PCM format, so VoiceGuide does not try to convert the files over to uLaw/ALaw after they are generated. Converting the sound files would add a delay and also add distortions to the sound file itself.