Jump to content

< Back to Forum


How Do I Set Vg To Dial And Record Immediately?

  • Please log in to reply

#1 newpop1 21 March 2008 - 06:05 AM

Ok, I am a bit confused and I apologize in advance if this is too simple but I can't find this anywhere here and in the help file. I found the script you have called DIAL AND RECORD, but how do you actually make that script run? We have a Dialogic analog card and VG 6.

here is what I need, we are having problems with certain numbers and we need to record the results after VG dials a number for testing. So we need VG to DIAL out a number we need to specify and immediately start recording to a file. Easy right? But we use config.xml which already has scripts assigned. So the question is how to tell VG to dial out using a script. I tried using OutDial_new.xml but the script only starts after the person answers the call and that is too late, how do I make VG dial out and immediately record?

thank You

#2 SupportTeam 21 March 2008 - 07:56 AM

So you would like to record the destination number ringing as well before it answers the call?

This needs to be a normal outbound call that just records everything that happens on the line immediately after the number is finished dialing, and not a recording of a "Dial and Conference" transfer, correct?

#3 newpop1 21 March 2008 - 08:24 AM

yes, it needs to dial, and immediately start recording to a file until it hangs up. Much like we did a while back to figure out frequencies for detecting dial tone, ring so we can look WAV. I can't remember how to do this and the help file just states: create a WAV file using the record module. I have that script from way back but I can't tell VG to dial a specific # and use that script, how do you do that?


#4 newpop1 24 March 2008 - 09:54 PM

Hello, were you able to look at this request? we need to get this done asap.

Thank You in advance.

#5 SupportTeam 25 March 2008 - 08:42 AM

Please try setting "disable" in the "Answering Machine Script" field.

This will disable the outgoing call progress detection on the Dialogic card, and should result in the "Human Answer" script starting immediately after the number is dialed.

#6 newpop1 25 March 2008 - 12:05 PM

Hello, not sure I understand, the OutDial_new.xml file is as follows:, can you tell me exactly how to modify this file to make it work, I can't find the field you are talking about. If not using the XML file, can you tell me exactly where to do this? Thanks

<OnAnswer>G:\Program Files\VoiceGuide\Scripts\Call Recorders\Dial and Record\Dial And Record.vgs</OnAnswer>

#7 SupportTeam 25 March 2008 - 12:09 PM

Try this:

<OnAnswer>G:\Program Files\VoiceGuide\Scripts\Call Recorders\Dial and Record\Dial And Record.vgs</OnAnswer>
<sOnAnswerMachine>disable</sOnAnswerMachine >

You can also try loading a call using the telephone number loader as well first, just to check that it works as expected.

#8 newpop1 25 March 2008 - 12:19 PM

I tried both methods and in both instances it waits, it does not start to record immediately after dialing, they both dial, then waits for AM to answer. Then the call hangs up after 30 secs, it only starts to record last 2 secs of the call. Please advise how to start recording immediately after dialing.

Thank You

#9 SupportTeam 25 March 2008 - 12:42 PM

Which version of VoiceGuide are you using? Please post log traces capturing the outgoing calls.

#10 newpop1 25 March 2008 - 01:17 PM

We have 6.03318 VG analog Dialogic board. Attached is log file.

#11 SupportTeam 25 March 2008 - 03:34 PM

Please update to the latest v6 available from our WWW and post the traces as before.

Please also post the OutDial_new.xml file which you are using.

#12 newpop1 25 March 2008 - 10:03 PM

Ok, the XML file is the same one you just gave me couple of messages ago. Updating to the new version won't make this recording work since we already made it work when we first install it months ago. I feel we are going around in circles. Can you tell me how to do this? We are evaluating purchasing more licenses and version 7 and this is not helping demonstrate how tech support works with the company. It has taken close to a week now just to ask this question that I remember was asked about a year ago and answered then. I will try to scan your forums again for the answer, this is not helpful going around and around.

#13 SupportTeam 25 March 2008 - 10:20 PM

The right approach, as mentioned before, is to set "disable" in the "Answering Machine Script" field.

The traces from your current VoiceGuide install (v6.0.3318) show that "Answering Machine Script" field is not being set to "disable".

This can be either because the v6.0.3318 is not reading the information in right, or the OutDial_new.xml file is incorrect.

Have you tried using the Telephone Number loader to load an outgoing call with the "Answering Machine Script" field set to "disable"?

#14 newpop1 25 March 2008 - 10:45 PM

Here is the XML, basically the same as above

<OnAnswer>G:\Program Files\VoiceGuide\Scripts\Call Recorders\Dial and Record\Dial And Record.vgs</OnAnswer>

I just tried again the telephone loader and it has the same behavior, it dials out, says AM - waiting... and after a while it starts recording for 2 seconds and hangs up. I added <sOnAnswerMachine>disable</sOnAnswerMachine> to the options and RV tab because I did not find anywhere a switch to disable this, is this where you put this?

We had a heck of a time getting version 6 to work properly (going from 5 that used to work flawlessly), even the registration number wouldn't work. In addition we were able to do this last year with the help from tech support and I do not remember this method. Is it something misspelled with the XML? is there another method? Thanks

#15 newpop1 25 March 2008 - 11:25 PM

I was able to finally find the answer by going back to old emails in an old account, the vg.ini setting below will stop AM from working and allow immediate recording. Maybe in Ver 7 the XML parameter works but in Ver 6 this is the only way.

;Dialogic cards can detect if an answering machine answers the call.
;To Enable Dialogic's answering machine detection set AM_DetectionMode to "Enabled"
;To Disable Dialogic's answering machine detection set AM_DetectionMode to "Disabled"

#16 SupportTeam 25 March 2008 - 11:27 PM

In v6 "Numbers Loader" the Answer Machine script/message setting is set in the second text line from the top. See the screenshot attached.
  • numbers_loader.gif

#17 SupportTeam 25 March 2008 - 11:37 PM

Using "disable" in the "Answering Machine Message" field allows turning off the call progress on per-call basis. The VG.INI approach would disable call progress detection for all outbound calls and transfers system-wide.