Jump to content

< Back to Forum


Cannot Config Anymore

  • Please log in to reply

#1 lorpar 16 August 2016 - 07:23 AM

I'm a registered customer. I had a perfectly working VG system up to a serious event which obliged me, 2 days ago, to reinstall everything (with no backup of previous configuration). I only had backup of my VG script and the sound files used by it.

I then reformatted the machine. Installed my dialogic HMP software (with its license for G729 codec / 4 lines). Installed Loquendo for the TTS I use (portuguese).

I then installed Voiceguide. I enabled my licenses in dialogic and voiceguide. i attepted to configure my Voip provider within config.xml, with no success (not working). I then installed microsip to test the line, and microsip can receive calls by my voip provider without problems. I tested dialogic using ipmediaserver.exe test (as suggested by your site). It works ... I could even get it answering in english when calling from another computer (with microsip) directly to my other IP. Bu when I call using my voip provider nothing happens. When I call the IP directly without ipmediaserver running nothing happens (no answer).


1) Microsip answers my Voip calls

2) Dialogic/ipmediaserver test answer my direct IP calls

3) Voiceguide says it is running with enterprise edition 4 lines.

4) Voiceguide does NOT answer both direct IP calls and Voip calls


I then guess the problem is with my config.xml file ... can you help me to find the problem and fix this all ?


Attaching my vg.ini , my congif.xml and log files of my last attempt to let all work !!



#2 SupportTeam 16 August 2016 - 08:00 AM

ktTel trace shows:


070 000438.369  5028     ERROR gc_start


It looks like you are using an older version of the HMP Drivers, which is now incompatible with newer releases of VoiceGuide:


013 000437.371  5028           szDSSVersion: 3.0, szDSSRelease: Dialogic ® Host Media Processing (HMP) Software Release 3.0 Service Update 349


Please update the system to the latest version of HMP drivers available from our WWW Downloads page and see if it makes a difference.


To update HMP please fully uninstall current version (do not save any configurations) then restart system then install new version and then restart system again - and only then start VoiceGuide service.

You may want to change VoiceGuide service startup mode to 'Manual' while the HMP re-install is being done. (in Control Panel -> AdministrativeTools -> Services -> VoiceGuide IVR)

#3 lorpar 16 August 2016 - 10:34 AM

So I uninstalled previous version of VG and reinstalled the old VG version I had which was running on my system before reformat. See previous message to know about version numbers.


It is now working when I call using microsip ( but my line monitor just shows 1 line (ID) as working, while I should have 4), meaning that when I call my direct IP using microsip VG answers and I can hear my VG script running.


When I call using my voip provider it just does not answer. 


When I try to enable microsip it works and answers. This means it must be some config problem related to voip. Important to observe that my voip provider just works with G729. I configures microsip to work with G729 and it works. Dialogic also should have G729 enabled (my license is for it) ... but dunno if I need to do anything special to enable it.


Any idea ??


If needed I can install wireshark (I remember I had to use it the first time to let VG work fine) ... or do any other test you can suggest.





#4 SupportTeam 16 August 2016 - 11:11 AM

Please collect a WireShark trace capturing the system startup and calls.


We can then see what happened with the SIP registrations and how the microsip calls and other calls were presented and handled.


To limit WireShark capture to just SIP  please specify this in the Wireshark's 'Filter' text box:




then use File->Export Specified Packets to save the displayed packets into a .pcpapng file.


The WireShark packet capture will show if the DTMF signalling is being sent to this system over the SIP/RTP connection.


Please .ZIP up all traces before posting. is the address of microsip and is the address of the VoiceGuide system, yes?


Who is the provider of SIP service at IP address ? Is it DirectDial / DirectCall ? ( directdial.com.br / directcall.com.br )



123 210338.463  4028     fn    VoIPProvider_AuthenticationAdd(auth_realm=, auth_identity=, auth_username=CSO71@, auth_password=******)
133 210338.480  4028     fn    VoIPProvider_Register(protocol=SIP, reg_server=, reg_client=CSO71@, local_alias=Disque, sH323SupportedPrefixes=)


204 210523.771  3688   3       gc_GetCallInfo ORIGINATION_ADDRESS=[]
205 210523.771  3688   3       gc_GetCallInfo DESTINATION_ADDRESS=[]

#5 lorpar 16 August 2016 - 11:30 AM is another PC in my local network which I use to make calls via microsip. This is the calling microsip. if the IP where VG is installed and the receiving microsip also. if the SIP server (directcall is the voip provider name).


I installed last version of wireshar (64bit). started it appears a textbox asking about filter: ... i write:    sip


then what shall I do to start capturing ??


After you this I will capture: 1) microsip answering voip incoming call   2) vg answering incoming net call with microsip from my other local pc. 3) VG nos answering voip incoming call.


Ok ??

#6 lorpar 16 August 2016 - 12:29 PM

attached the WireShark capture log ... hope I did it right, if not please instruct me about how to do it.


First I turned off dialogic and VG. Then I started wireshark capture and then I did the following:


1) start microsip configured to connect to my Voip provider and answer calls.

2) called using a cellphone to my voip number ... microsip answered normally.

3) turned off microsip

4) started dialogic

5) started voiceguide

6) called voiceguide directly on the machine IP (using microsip from other PC). Is answered normally

7) called to my voip number (using cellphone) where voiceguide should answer. Nothing happened.


Let me know what you can find to help me ... thanks !!




#7 SupportTeam 16 August 2016 - 01:01 PM

As you are using an older version of VoiceGuide you may need to set this in Config.xml's <VoIP_Authentication> section :




Please make that change and restart VoiceGuide service. Please make WireShark capture as before if you still encounter problems, and post the WireShark trace along with the ktTel trace file.


In newer versions of VoiceGuide setting the "Realm" entry is not necessary if only one source of calls is being registered.

  • ws.png

#8 lorpar 16 August 2016 - 01:51 PM

Same as before ... i changed the config.xml but nothing worked differently.


Microsip working and receiving voip calls.

VG receiving call when directly to IP and not when from voip.


I captured wireshark again (attached);


This time, after changind config.xml and starting wireshark i did the following:


1) started dialogic

2) started VG (with new config.xml)

3) called using voip (no answer)

4) called using direct IP (answered well).

5) turned off VG and Dialogic

6) turned on microsip to receive voip calls

7) called voip number and microsip answered without problems


Attached i'm sending config.xml, wireshak log and VG logs (ktel engine ...) ... all zipped in one file.


Thanks for your help.







#9 SupportTeam 16 August 2016 - 02:56 PM

It looks like you now have VoiceGuide installed at IP address ?

and there are INVITEs from that come from Microsip?

But there is also Microsip installed at right?



Please ensure that the system that has VoiceGuide installed on if has no other SIP software installed on it. Multiple SIP programs on same system will interfere with one another.


Also please ensure that no other SIP devices or software is trying to register that same SIP number.


Then after uninstalling Microsip (and any other SIP software) from the VoiceGuide machine just restart that machine and capture in WireShark the VoiceGuide service startup (and hence the REGISTER messages) and then place one call into the registered number (via DirectDial / DirectCall)


This should give us a clear picture of what is happening.


Please the post the WireShark and ktTel traces as before.

  • ws2.png

#10 lorpar 16 August 2016 - 04:04 PM

My structureis as follows. I have a cable link modem at this goes to a router to which two computers are connected.

In local network the two computers have following local IPs and .

The first (ending with 4) is the computer where VG is running (i also had a microsip installed there to test incoming voip line, which worked) the second (ending with 2) is the computer from which i made direct IP calls (using microsip). 


I have now uninstalled microsip from the computer where VG is running, as instructed ... there is no other software there but dialogic and VG. I made a reboot of that computer. When started back i turned off dialogic and VG. I started Wireshark capture. I then started dialogic and then started VG.

I made an attempt to call my voip number (at directcall) using a cellphone. It did not answer. 

I have no more microsip in this computer but when I had it was able to answer voip calls from directcall (as shown in previous logs).


Attached wireshark capture file and Ktel log. I also send a capture screen of my dialogic setup proving I have enhanced version which should run G729 as required by directall. Directcall just works with G729.




#11 lorpar 16 August 2016 - 04:35 PM

forgot to say, but is obvious. Router in at

#12 SupportTeam 16 August 2016 - 05:26 PM

We can see that Dialogic HMP is doing registration and is supplying the Digest Authenticated Response, but now the DirectDial / DirectCall SIP server responds with:


403 : Forbidden


You could ask DirectDial why their server is replying with Forbidden, but most likely it's the Alias / Contact setting.


Right now you have the Alias to be just:




This is not a valid SIP "user@host" type URI expression. Suggest leaving the <LocalAlias> entry (in Config.xml <VoIP_Registration> section) blank, or setting it to a valid SIP "user@host" URI eg: Disque@ or CSO71@, so either:











  • ws3.png

#13 lorpar 16 August 2016 - 05:50 PM

I removed the "Disque" ... now it is <LocalAlias></LocalAlias>

I restarted dialogic and VG and tried a voip call ... but still not answering. I'm sending wireshark again.


Just to try to understand ... microsip was able to receive voip call on this machine. How was microsip dealing regarding localalias and other parameters when it succeded to connect and answer ? Can't we just reproduce it in some way ?


Attached new wireshark capture, new config and ktel log.




#14 SupportTeam 16 August 2016 - 06:53 PM

Attached WireShark trace does not capture any SIP communications.


Looking at Microsip's REGISTER message in WireShark we can see that it is setting the "Contact:" field, so you could try using








or maybe try:






and see if this makes any difference.



Please ensure that that SIP account is not being registered by Microsip or any other sip agent on another system at the same time.

#15 SupportTeam 16 August 2016 - 07:34 PM

Are you sure the password specified in your Config.xml <AuthPassword> section is correct ?


The response:


403 : Forbidden


is also used to indicate the password is not correct...

#16 lorpar 16 August 2016 - 10:19 PM

it is the same password used by microsip ... 

#17 lorpar 16 August 2016 - 11:14 PM

I contacted directcall and they say that 403:forbidden means that it does not even goes out of my network. It is a local block ... not from them.

I made an attept to turn on VG with the guy from directcall online monitoring his sip server and he did no receive any request to log in from my public IP.

It could be a firewall problema, but yerterday i turned off my firewall just to configure VG without this possible problem. 

Then i reinstalled microsip on same machine, configures with same credential (taken from VG config.xml) and it connected successfully ... the guy from directcall confirmed this from his SIp server log.

The problem seems to be somewhere among Dialogic and Voiceguide 

#18 lorpar 16 August 2016 - 11:36 PM

indeed ... I made again the previously described attempts. I started wireshark and then started microsip. It connects and I capture the SIP connection without problems. Then i turno off microsip and start dialogic and then VG and I can not see in wireshark any SIP protocol record.

What can cause dialogic/VG not to reach the SIP server ? Take in account that there is no firewall there now .. 

If you want i can even give you remote access to this machine ... in order to see (the OS is in english).

Attached the last Wireshark logs (as described above).




#19 SupportTeam 17 August 2016 - 07:26 AM

A number of traces have been posted before where the registration negotiation can be seen to be made with and the 407 response that comes from specifies that the "Realm" to use is "Directcall".


So there is no doubt that these communications came from the DirectCall's servers.


The three screenshots posted for 3 different traces show this - and the traces are in the respective preceding posts.


The trace posted just now does not capture any SIP traffic.


We offer an installation service during which we can log into your system remotely (using TeamViewer / join.me / etc.). Please contact sales@voiceguide.com to inquire about this option. (please include link to this Support Forum thread in the email).

#20 lorpar 17 August 2016 - 08:10 AM

I have just revised all traces posted before. All the ones where the "realm Directcall" is mentioned are related to my microsip connections.

I did not see any one made by VG or Dialogic HMP.

Indeed microsip can connect without problems.

As i informed I made the test with directcall people online and they saw it registering in the SIP server. When turno off microsip and start VG they see nothing arriving there ... not even an attempt to register from my IP.

There must be some problem which I guess is not just a config.xml misconfiguration ... Do you have any idea of why VG and dialogic could not even send a request to register in the SIP server ??

I just uninstalled and reinstalled my VoiceGuide ... but nothing changed.





#21 lorpar 17 August 2016 - 08:46 AM

Ok ... after many attempts, I got a SIP message from VG/dialogic captured in wireshark ... with an answer 407 proxy autentication required.

But I am not using a proxy nor have one ... 

#22 lorpar 17 August 2016 - 10:50 AM

Unfortunately I have no budget to hire paid remote service. My next budget available will have to be to buy 4 more lines of voiceguide (a 4 more licenses of dialogic HMP) ... but before I need to put this to work back.


Well by attempt by attempt, I got to a point in which I can compare microsip with VG ... i have both getting a 407 proxy auth required, and they they both try to register (100 trying). The difference is that microsip gets a 200 OK ... and VG gets a 403 forbidden.

I noticed that one of the differences is that microsip does not set TTL while VG set a TTL=10 ... could not this be a problem (some kind of timeout) ?? Is there a way to chnge this value or just not provie the TTL parameter ?


Thanks as usual.



#23 SupportTeam 17 August 2016 - 01:52 PM

VG gets a 403 forbidden


Now that you are seeing the 403 being returned from DirectCall you should be able to ask DirectCall why they are sending back that response. They should be able to see why their system is responding with a 403.


Every time the VoiceGuide service is started the registration attempt will be made and the REGISTER messages issued to DirectCall - and you can monitor these on WireShark, and DirectCall can monitor them on their end.

#24 lorpar 17 August 2016 - 11:27 PM

Solver ... it was just matter to configurecorrectly the config.xml. just put the SIP server IP in the voip registration, and just credentials (without any IP) in voip autetication. Thanks and regards

#25 lorpar 18 August 2016 - 06:27 AM

I now have another problem. My VG should have 4 lines (that is my license both for VG and dialogic) ... but just one line is answering (when one line is busy it does not answer a second one). Is there any configuration I need to set to let the 4 lines work ?

#26 SupportTeam 18 August 2016 - 07:26 AM

The lines to open need to be specified in the Config.xml file.


Looks like right now only one line is specified there.


Here is the excerpt from Config.xml that shows how 4 lines on a VoIP system should be specified. The below are the contents of the <Channels> section:


<Script>C:\Program Files (x86)\VoiceGuide\Scripts\Credit Card Payment\Credit Card Payment.vgs</Script>
<Script>C:\Program Files (x86)\VoiceGuide\Scripts\Credit Card Payment\Credit Card Payment.vgs</Script>
<Script>C:\Program Files (x86)\VoiceGuide\Scripts\Credit Card Payment\Credit Card Payment.vgs</Script>
<Script>C:\Program Files (x86)\VoiceGuide\Scripts\Credit Card Payment\Credit Card Payment.vgs</Script>


(in above replace the script with path to your own script.)


Example Config.xml files are also included in the VoiceGuide's \conf\ subdirectory.