Jump to content

< Back to Forum


Testing Dialogic Hmp Installation

  • Please log in to reply

#1 ThaoHuynh 24 March 2017 - 05:29 PM

Hi VoiceGuide Team,


I have tested this HMP installation using Dialogic's own IPMediaServer.exe test application. It worked.

And i want to dial the IP address of HMP machine from a Linphone on another machine, to make sure HMP is correctly installed and works correctly.

I have installed Linphone in another machine.

        SIP address is: sip:phuongthaohuynh@sip.linphone.org

        IP address of HMP machine:

How can i make the call?


Thank you your help.

Thao Huynh


#2 SupportTeam 24 March 2017 - 06:07 PM

You will just need to Dial the IP address of HMP machine,


Not sure how to dial IP on Linphone


SJPhone is one application that we know allows you dial IP address.


You may also want to use WireShark to confirm SIP operation.

#3 ThaoHuynh 27 March 2017 - 01:13 PM

Hi VoiceGuide Team,
I have installel WireShark to confirm SIP operation. How can i configure VoiceGuide? (<VoIP_Registrations> and <VoIP_Authentications>)

I attached the .pcapng file. Please check it.


Thank you your help.

Thao Huynh

#4 SupportTeam 27 March 2017 - 01:19 PM

No file was attached. Please .ZIP up the .pcapng file and try attaching the .ZIP file.


To test initial operation the registration/authentication does not need to be set up. Just place SIP calls direct to IP address of VoiceGuide system.

#5 ThaoHuynh 27 March 2017 - 01:25 PM

This is my .pcapng file.

#6 SupportTeam 27 March 2017 - 02:14 PM

Trace shows two calls coming in from SJPhone on system to system, with first call connected for over 30 seconds and second call connected for about 10 seconds.


What is the actual problem here?


Is the Ip address of the VoiceGuide system?


Did you hear VoiceGuide answer the calls?


If VoiceGuide did not answer the calls then do you perhaps have some other VoIP software installed on the192.168.76.21 system that answered that call instead? ...

  • ws.gif

#7 ThaoHuynh 27 March 2017 - 04:48 PM

I have uninstalled VoIP software on system. And I test call into the system by dialing 17778296701  from SJPhone on another system. But i didn't hear VoiceGuide answer the calls?

I attached the config.xml file. Please check it.

#8 SupportTeam 27 March 2017 - 04:57 PM

Is the IP address of the VoiceGuide system?


Please use SJPhone (or any other SIP software that can dia lIP addresses) to just place call to directly.


WireShark trace provided before shows that you have placed calls from to directly beforehand. Please place call to directly in the same way.


Please advise when VoiceGuide is answering calls placed direct to its IP address this way.

#9 ThaoHuynh 27 March 2017 - 05:11 PM

It means i have installed VoiceGuide system + SJPhone in and SJPhone in And i can dial IP address. Is that right?

#10 SupportTeam 27 March 2017 - 05:16 PM

No other VoIP/SIP software can be installed on HMP+VoiceGuide system. It will interfere with HMP+VoiceGuide operation.


If you currently have SJPhone or any other VoIP software installed on VoiceGuide system then please uninstall it and then restart the VoiceGuide machine.


After restart of VoiceGuide machine please then place calls into that system ( from another SIP software on another system (eg. from SJPhone on

#11 ThaoHuynh 27 March 2017 - 05:45 PM

Thank you so much for your help.

This is my .pcapng file. How can i modify my config.xml?

#12 SupportTeam 27 March 2017 - 05:57 PM

Attached WireShark trace shows one call coming in from SJPhone on system to system, with the call connected for about 30 seconds.


Did VoiceGuide answer that call?


Could you hear the prompts played by VoiceGuide and did you press some keys on the telephone keypad and could see that VoiceGuide detected those keypresses?


Please make WireShark traces using this filter :


sip & rtp


We can then see the sound transmitted by both sides of the conversation.

#13 ThaoHuynh 27 March 2017 - 06:12 PM

VoiceGuide didn't answer that call. In SJPhone, i just hear the ring. I can't see the keypad or anything on VoiceGuide.

#14 SupportTeam 27 March 2017 - 06:37 PM

The trace just posted shows the incoming SIP INVITEs are not answered. No SIP software is running on the system. Was the VoiceGuide service started?


VoiceGuide does not have a 'keypad'. VoiceGuide has a Line Status Monitor.


The trace just prior to it shows that incoming call was answered by something on


What was changed on machine between these two traces?

#15 ThaoHuynh 27 March 2017 - 07:17 PM

I think it produces an error because i haven't VoIP register in Config.xml

#16 ThaoHuynh 27 March 2017 - 07:28 PM

I use SJPhone. Where is AuthUsername and AuthPassword?

#17 SupportTeam 27 March 2017 - 07:34 PM

Status of VoIP registration does not affect whether the system can or cannot answer calls sent direct to its IP address.


IP direct calls need to work first. If they do not work then any calls sent to the system from registered numbers will also not work. The VoIP services just send calls to the IP address of the system as well. The IP address is advised to the registration service during the registration.


You had Dialogic HMP answering the call in the trace posted before


See the screenshot of that trace. It shows that Dialogic HMP answered the call.


What was changed on machine since that time? Did you perhaps stop the Dialogic HMP or VoiceGuide service?

  • ws2.gif

#18 ThaoHuynh 27 March 2017 - 07:49 PM

It worked. Thank you so much.

Line Status Monitor didn't show any lines

#19 SupportTeam 27 March 2017 - 08:03 PM

Please try restarting the Line Status Monitor.


Line Status Monitor needs to be started after VoiceGuide service is started.


Line Status Monitor will show at least 1 line when running in HMP and VoiceGuide in Evaluation mode,

#20 ThaoHuynh 27 March 2017 - 08:21 PM

It's still not working. When i clicked telephone icon, it's show message "No lines highlighted. Not hanging up any lines". It's also not connect to net.tcp://localhost:7134/PortStatus/

#21 SupportTeam 27 March 2017 - 08:28 PM

Is the VoiceGuide service running? There should be a "IVR" icon in the bottom right "Tray". does it show the service running?


Right click on that IVR icon the stop the service and after it has stopped then start the service again and then start the Line Status Monitor after the VoiceGuide IVR service has started.

#22 ThaoHuynh 27 March 2017 - 08:32 PM

I have tried but it's still not working.

  • LineStatus.png

#23 SupportTeam 27 March 2017 - 10:39 PM

Can you please advise what version of Windows is used on this system?


Is anything else installed on this system apart from Windows and HMP and VoiceGuide? Any 'anti-virus' type applications?


Are you logged as a user with Administrator privileges when starting the Line Status Monitor? Have you tried starting the Line Status Monitor using the "Run as Administrator" option?


Can you please . ZIP up VoiceGuide's log files (in VoiceGuide's \log\ sub-directory) and post them here. We can then better see what is happening on this system.

#24 ThaoHuynh 28 March 2017 - 12:14 PM

Windows 7 Professtional Service Pack 1

I have uninstalled anti-virus software.

I also tried starting Line Status Monitor using the "Run as Administrator"


  • Attached File  log.zip   101.13KB   42 downloads

#25 SupportTeam 28 March 2017 - 02:01 PM

The .ZIP just posted has traces beginning from 16:04 (4:04 PM) on 27th March.


In traces provided the VoiceGuide service was restarted 8 times between 16:04 and 17:29.


Each time it did not start properly.


We can see errors in trace like this for each start time:

078 160447.074  5168     ERROR gc_start
079 160447.074  5168   1 ERROR StartDialogicGlobalCall returned -1

160447.143   9         ERROR LineOpen failed for iIvrDev=1, <port>1</port>

Are you sure there are no other VoIP applications/utilities running on this system at the same time?


You were able to receive calls before. Did anything change?




Can you please open the Windows Task Manager and locate the vgIvrService.exe process.


Exit all VoiceGuide applications (especially the Line Status Monitor).


Then Stop the VoiceGuide service.


Look in Windows Task Manager and confirm that the vgIvrService.exe process exits. ie. disappears from the active processes list.


Does vgIvrService.exe process exits by itself?

If it does not then the Right click and select "End Task".


Then wait a 10 seconds or so and start the VoiceGuide service.


Check traces to see if HMP did initialize correctly.


Please post traces as before.