Jump to content

< Back to Forum


Email Problems

  • Please log in to reply

#1 Lbud 27 January 2017 - 02:20 AM

I am rebuilding my Voicemail computer I built about 9 - 10 years ago. It was running Voiceguide software and had a Dialogic ISA bus card. I am rebuilding it with a PCI bus card. It a simple Voicemail server with a couple of Mailboxes and one mailbox needs to send an Email out. The old system worked fine until the computer seen its days.


The one I am building is running Windows XP. Everything is working OK except it won't send the Email. I tried 3 different Email addresses and also tried Outlook 2007 with no luck. Note: it is running the Evaluation software.


So, I decided to make a test script. I put four modules in it. The start module  is the Send Email the three others are Play Sound File modules. The three paths from the Send Email module go to the three Play Sound Files for (success, fail, and timeout). When I run it I get success sound, but no Email is every received on the receiving email account. This is the log file results:


{ "call": {
  "crn": "10000001",
  "port": "4",
  "direction": "in",
  "time_start": "2017-01-26 09:07:12",
  "events": "
    090712.015|state|Ring 1 connected|||||0|0|0|0
    090712.156|state|[Send Email] Send Email|||||0|0|0|0
    090712.343|state|[Play 3] Playing wav (C:\Documents and Settings\User\My Documents\the email was sent.wav)|||||0|0|0|0
    090718.828|state|Hanging up... [Loop Current Off (non-xfer vgm)]|||||0|0|0|0
  "length": "7.516"


The log seams to show everything worked ok.


I don't know why the Emails are not sending?


Any help in this matter would be appreciated.


#2 SupportTeam 27 January 2017 - 02:32 AM

Could you please post the vgEngine trace file which captures system startup and the call during which the email send was attempted.

#3 Lbud 27 January 2017 - 04:43 AM

If you are talking about 0126_1332_vgEngine.txt file in log folder its empty.

#4 SupportTeam 27 January 2017 - 04:46 AM

Could you please post the output of DIR command on VoiceGuide's \log\ sub-directory.

#5 Lbud 27 January 2017 - 05:01 AM

I went into the vg.ini and the log was turned off, here it is:


134940.953   5               ------------------------------------------------------------------------------------------------------
134940.953   5               vgEngine : 7.5.6117.35767 RELEASE options75
134940.953   5               Compiled : 30-Sep-16 18:52:14.30
134943.750   5               Voicemail LoadIniSettings
134943.843   5               read Config.xml //devicesSysManagers/StatusLink end
134946.515   7         reg   *******************************************************
134946.515   7         reg   UNREGISTERED EVALUATION VERSION, lines: 30 id:  | FD082234
134946.515   7         reg   *******************************************************
134947.875  13               Db_TestTables start, conn.DataSource=vgDb, Provider=System.Data.SQLite
134947.875  13               Db_TestTables callque ExecuteScalar SELECT COUNT(*) FROM callque call (default)
134947.875  13               Db_TestTables calltrack ExecuteScalar SELECT COUNT(*) FROM calltrack call (default)

#6 SupportTeam 27 January 2017 - 05:27 AM

In VG.INI in section [Log] please set the VoiceGuide entry to 10, like this:




Then restart the VoiceGuide service and place a call into the system that attempts to send and email during the VoiceGuide scirpt.


Then please .ZIP up and post the vgEngine trace file that captured that startup and call here.

#7 Lbud 27 January 2017 - 05:37 AM

I found a problem when I was moving the old program over I must have put the old vg.ini in. I put new one back in still not working but I have the log you were looking for. I noticed that the port is set to 25 which I don't  think works anymore it needs 587, but when I use 587 I get an error.


log is attached.

#8 SupportTeam 27 January 2017 - 05:50 AM

The VoiceGuide service was stopped 10 seconds after the email send attempt, and the log does not contain any information on why the email was not sent out.


Could you please repeat the test, but this time let the VoiceGuide service run for 5 minutes afterwards. We should then see some log entries that would show us what error was encountered.


Also, are you able to use WireShark to monitor the email related communications of of this system? Please post WireShark trace as well if possible.

#9 SupportTeam 27 January 2017 - 05:58 AM

Verizon online support says that the email server name to use for outgoing email should be:




and the port number should be:




Please see:



#10 Lbud 27 January 2017 - 06:32 AM

Your right settings were wrong, I been working on it for 2 days using 3 different Email accounts and also Outlook to get this to work and nothing.

I changed it to smtp.verizon.net and port 465 and the TEST program says success but still no email. I tested Outlook to make sure it was sending emails and it was, but it won't do it through the Test program either.

I don't care how to send the Email I just need it to work.

The Aol account use port 587 with TLS security. I think if I leave the port blank it use port 25 and if I put in 587 the security is set to SSL probably why Aol is not working.

I attached the log from the changed verizon account.

By the way I am only testing my test program not the voicemail program. I noticed the log file has both. The test is on line 4.


#11 SupportTeam 27 January 2017 - 06:35 AM

I tested Outlook to make sure it was sending emails and it was,


What email server and port settings were used to send the message out using Outlook ?


Same settings should be used in VoiceGuide.


Also: in the attached 0126_1525_vgEngine.txt trace the VoiceGuide service was shutdown less then 20 seconds after the email send attempt.


Please let the VoiceGuide service run for 5 minutes after the email send attempt. We should then see some log entries that would show us what error was encountered.

#12 Lbud 27 January 2017 - 07:41 AM

I wiped out the software and reloaded to make sure I did not overwrite and other file like the vg.ini. I ran test still no good.

The outlook is using an Aol account. I tested Outlook to make sure it works, and it sends Emails fine.

I ran the test with mapi and program reports an Error.

I attached the log.



#13 SupportTeam 27 January 2017 - 07:50 AM

In VoiceGuide v7 you cannot use "MAPI" to send the email.


You must use SMTP.


Please try using the same SMTP settings as are used in your Outlook.

#14 Lbud 27 January 2017 - 07:52 AM

I'm sorry I didn't read you reply carefully.

When you setup Mapi there are no settings to set in Voiceguide Send Email module?

The Error is coming out immediately.

I waited this time 5 minutes.


#15 SupportTeam 27 January 2017 - 07:56 AM

In VoiceGuide v7 you cannot use "MAPI" to send the email.


You must use SMTP.


Please try using the same SMTP settings as are used in your Outlook.

#16 Lbud 27 January 2017 - 08:04 AM

I am using Aol for Outlook it use port 587 and tls security, I don't know if Voiceguide works with that?

I attached log file.

#17 SupportTeam 27 January 2017 - 08:08 AM

0126_1657_vgEngine.txt  trace shows that the email server name to use for outgoing email was set to be:




this is an invalid name and hence and error occurred.


Please confirm the server name that is used in working Outlook.

#18 Lbud 27 January 2017 - 11:56 PM

I don't where it came up with that?

I attached a picture of the settings screen.

  • settings.JPG

#19 Lbud 28 January 2017 - 01:33 AM

I ran another test and I see a problem.

I used my verizon account.

settings: smtp.verizon.net port=465 requires ssl

but when I look in the log it shows .EnableSSLl=false

I attached log:

#20 SupportTeam 28 January 2017 - 06:01 AM

Please change:








There is a bug right now that if port 587 is specified then this prefix:




must be added to the server name.




also, if the connection to smtp.verizon.net on port 465 must be an SSL connection the please specify the verizon server as:



#21 Lbud 28 January 2017 - 07:54 AM

Well we are getting somewhere.

In the test program the change worked for Aol & Verizon.

In the Voicemail Server program it got an error.


I am leaving soon, I will left you know whats up.


#22 SupportTeam 28 January 2017 - 08:03 AM

Please post vgEngine trace capturing call handled by Voicemail scripts.

#23 Lbud 29 January 2017 - 02:32 AM

Ok, I want to let you know the results of all my tests. First I was a little premature with the results of the test program, Aol does not always work, sometimes the email never reaches the destination (without changing any settings). The Verizon and Optimum accounts work fine.

With the voicemail program, the Verizon account works but only with Port 587 not Port 465 I don't know why. I tried it with an Optimum account and it works fine. As for Aol the log seems to says the Email sent ok but it never reaches the recipient.


The attached log is for Aol with the Voicemail Server:


#24 SupportTeam 29 January 2017 - 05:27 AM

Attached trace shows that Microsoft's email sending modules have advised that the email was sent out through the smtp.aol.com email server.


You may need to next monitor the IP level communications using WireShark to confirm, and/or contact AOL to resolve why the email did not arrive at destination.


As sending through Verizon and Optimum accounts works fine then it may be just simplest to use Verizon and/or Optimum to send out the emails.

105444.625  12   1   1 rem   Vm_Event 1, FORWARD, 0001, C:\Program Files\VoiceGuide\data\VmSave\0001_0128105437_1_1__.wav, ,
105444.656  12   1   1       vm    forward vmb 0001
105444.671  12   1   1       vm    forward vmb 0001 email to lbudltc@yahoo.com (wav attached)
105444.687  12               AddEmailToSend from:advancedpumpinc@aol.com|VoiceGuide Voicemail, to:lbudltc@yahoo.com, cc:, bcc:, reply:advancedpumpinc@aol.com, subj:Voicemail: ,  on 1/28/2017 10:54:44 AM at 10:54:44, att:C:\Program Files\VoiceGuide\data\VmSave\0001_0128105437_1_1__.wav, usertoken:(<to>lbudltc@yahoo.com</to><subject>Voicemail: ,  on 1/28/2017 10:54:44 AM at 10:54:44</subject><guid>ccb71ff6-f78c-4d95-bc43-d33e2c819976</guid>) smtp:ssl:smtp.aol.com|587 timeout:1500sec, sParamsXml:
105444.703  12               SmtpClient created ok
105444.718  12               setting EnableSsl as port = 587
105444.718  12               .Host=smtp.aol.com .Port=587 .EnableSsl=True sCredentialUserName=[advancedpumpinc@aol.com]
105444.718  12               SmtpClient clientEs configured ok, await EmailSendCompletedCallback, clientEs.Timeout=1500000
105444.718  12               email send start <to>lbudltc@yahoo.com</to><subject>Voicemail: ,  on 1/28/2017 10:54:44 AM at 10:54:44</subject><guid>ccb71ff6-f78c-4d95-bc43-d33e2c819976</guid>, timeout=1500sec
105444.734  12               email SendAsync returned
105444.734  12   1   1       vm    frwrd vmb 0001 end
105444.734  12   1   1       vm    MsgLamp control set to [DISABLE]
105444.734  12   1   1 rem   Run_ResultReturn [success] 7

105445.718  11         email EmailSendCompletedCallback email sent ok. <to>lbudltc@yahoo.com</to><subject>Voicemail: ,  on 1/28/2017 10:54:44 AM at 10:54:44</subject><guid>ccb71ff6-f78c-4d95-bc43-d33e2c819976</guid>

#25 Lbud 31 January 2017 - 01:01 AM

I agree, Aol is probably the problem. I would have liked to use it, but will use Optimum instead.  Thanks for the help.

#26 Lbud 01 February 2017 - 12:46 AM

Just wanted to update you. I found the problem with not receiving the AOL Emails. It turned out to be the Yahoo Email account I was sending them to. Yahoo was rejecting some of the Emails. There was something in the Email it didn't like (I don't know what). When I use AOL to send the Emails to any other provider the Emails go through without any problem.