Jump to content

< Back to Forum


Run Program Fails

  • Please log in to reply

#1 Simon Dupras 20 May 2017 - 07:01 AM



We're trying to debug an issue with our VoiceGuide system. In order to do so, we created a simpler process with a single Run Program step. This is the log we have after going through the process.


160342.779   8   4   3       RunModule start Run Program, [Run Program 47], iModuleIdx=5, previous: vgm=4, vgs=2:2

160342.783   8   4   3       state [Run Program 47] Run Program

160342.786   8   4   3       File.Exists(C:\Program Files (x86)\RealPopup\RealPopup.exe) is true

160342.786   8   4   3       running program=[C:\Program Files (x86)\RealPopup\RealPopup.exe], arguments=[-send "computername" "test from bat file"], windowStyle=Hide, RunWait=0

160342.788   8   4   3       ShellExe start [C:\Program Files (x86)\RealPopup\RealPopup.exe][-send "computername" "test from bat file"] UseShellExecute=0

160342.796   8   4   3       process start failed


As you can see, we're running a command line with arguments. When running the same command from a command prompt, there is no issue. We also tried having the UseShellExecute setting set to either 0 or 1 in the .ini file, but with the same results. We also made sure to have the RealPopup program to run as administrator.


What could be causing the Run program step to fail ?



#2 SupportTeam 20 May 2017 - 09:18 AM

Does the ran EXE (RealPopup.exe) display a GUI to a user when it is started?


If so, is it possible to start it in mode where it does not display a GUI ?


VoiceGuide runs as a Windows Service and on current versions of Windows is not possible to start applications that use GUI from within a Windows Service.


Can this RealPopup.exe be downloaded for evaluation from the program's publisher? If so then could you please provide a link? We can then verify operation on our test systems.

#3 SupportTeam 22 May 2017 - 07:00 PM

Please try updating to version below and see if this results in your RealPopup.exe program now running when started from the Windows Service:


[old link removed]


The above version attempts to start the program in a slightly different way if the normal method fails.

This new approach however requires that there is a user logged into the system. The program is then started as running in that users login session (the window is however hidden).


Please post traces capturing the call when using this new version and we will be able to verify how it works when trying to run that program on your system.

#4 Simon Dupras 23 May 2017 - 06:48 AM

I modified the command line to not display a GUI, but I get the same result with the step : process start failed.


We did not update with the version mentioned in the previous post yet. We need to verify some things before we can do that.

#5 andrewfleury 24 May 2017 - 12:25 AM

100704.267   8   2   2 state [Run Program 47] Run Program
100704.271   8   2   2       File.Exists(C:\Program Files (x86)\RealPopup\RealPopup.exe) is true
100704.271   8   2   2       running program=[C:\Program Files (x86)\RealPopup\RealPopup.exe], arguments=[-send -noactivate "computername" "test from vg"], RunWait=0
100704.272   8   2   2       ShellExe start [C:\Program Files (x86)\RealPopup\RealPopup.exe][-send -noactivate "computername" "test from vg"] UseShellExecute=0
100704.274   8   2   2       WindowStyle set to ProcessWindowStyle.Hidden
100704.277   8   2   2       start non-UI process failed. Trying to start process as logged in user. (requires an active user login session on system)
100704.285   8   2   2       start user process: hProcess=1148, dwProcessId=732, hThread=12732, dwThreadId=2768
100704.285   8   2   2       RunModule finish

After installing the supplied version above

#6 SupportTeam 24 May 2017 - 05:27 AM

It looks from above trace that the .exe was now started.


This line from above log excerpt gives information on the started process:

100704.285   8   2   2       start user process: hProcess=1148, dwProcessId=732, hThread=12732, dwThreadId=2768

#7 SupportTeam 26 June 2017 - 02:58 PM

We can see now the issue here was that script was not going down 'Success' path after starting the RealPopup.exe


This should now be fixed in this version:


[old link removed]



To change from one release of VoiceGuide v7 to another:

1. Stop VoiceGuide Service and exit all VoiceGuide programs. (eg Script Designer, Voicemail Manager, etc) and all other programs.

2. Run the VoiceGuide install and install into same directory as existing installation. (Do NOT uninstall the previous VoiceGuide installation).

3. Start  VoiceGuide service.


Running a VoiceGuide install over the top of an existing install will NOT overwrite existing configuration or license files (Config.xml, ConfigLine.xml, VG.INI, VmBoxList.xml, etc) and will not remove any of users script or sound files, and will not remove any log files etc.